OpenSSL phát hành bản vá cho nhiều lỗ hổng nghiêm trọng

5/9/2023 6:40:00 PM

 Nhóm dự án OpenSSL vừa phát hành một bản cập nhật an ninh lớn, khắc phục ít nhất 8 lỗ hổng. Người dùng OpenSSL có nguy cơ hứng chịu những cuộc tấn công mã độc nếu gặp phải các lỗ hổng này.


Lỗi nghiêm trọng nhất, có mã định danh CVE-2023-0286, có thể cho phép kẻ tấn công trỏ tùy ý tới lệnh gọi memcmp, cho phép đọc nội dung bộ nhớ hoặc tấn công từ chối dịch vụ.

20230415-pg36.png
 

Lỗ hổng được đánh giá có mức nghiêm trọng cao. Tuy nhiên, lỗ hổng chỉ ảnh hưởng đến các ứng dụng đã triển khai chức năng riêng để truy xuất CRL qua mạng.

Các tổ chức đang chạy OpenSSL phiên bản 3.0, 1.1.1 và 1.0.2 được khuyến cáo áp dụng các bản nâng cấp ngay lập tức.

Dự án mã nguồn mở cũng ghi nhận 7 vấn đề ở mức nghiêm trọng trung bình; trong đó đáng lưu ý là:

• Lỗ hổng timing based side channel (CVE-2022-4304) tồn tại trong quá trình triển khai Giải mã OpenSSL RSA. Lỗ hổng có thể khôi phục văn bản gốc trong một cuộc tấn công kiểu Bleichenbacher. Để giải mã thành công, kẻ tấn công phải gửi một lượng rất lớn tin nhắn thử nghiệm. Lỗ hổng ảnh hưởng đến tất cả các chế độ đệm RSA padding: PKCS#1 v1.5, RSA-OEAP và RSASVE.

• Lỗi tràn bộ đệm có thể được kích hoạt trong quá trình xác minh chứng chỉ X.509, cụ thể là trong quá trình kiểm tra tên. Lỗ hổng có thể dẫn đến tấn công từ chối dịch vụ.

Nhóm cũng vá nhiều lỗ hổng bộ nhớ khác, đều là các lỗ hổng khiến người dùng OpenSSL có thể bị tấn công từ chối dịch vụ.

 

theo whitehat.vn